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1. Introduction 

1.1. Overview 

The Clip Converter Plug-In for Adobe Premiere Pro and Adobe After Effects (herein referred to as CLP 

Importer and CLP Exporter) is an importer/exporter plug-in for Adobe Systems nonlinear editing software, 

Adobe Premiere Pro and Adobe After Effects, that supports "CLP," the AV-HS6000/AV-HS73000 Live 

Switcher's proprietary video (clip) codec. The following functions are available on CLP Importer and CLP 

Exporter. 

 

 CLP Importer 
 Import CLP format files to Adobe Premiere Pro / Adobe After Effects. 

 

 CLP Exporter 
 Export Adobe Premiere Pro / Adobe After Effects sequences and compositions in CLP format. 

 

CLP Importer and CLP Exporter can be used with Premiere Pro CC and CC 2014, and After Effects CC 

and CC2014. 
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1.2. System requirements 

The system requirements for CLP Importer and CLP Exporter are indicated in Table 1-1. 

(The requirements correspond with those of Adobe Premiere Pro CC and After Effects CC.) 

 

Table 1-1: System requirements 

Item Description 

Host application 
Adobe Premiere Pro CC, CC 2014 
Adobe After Effects CC, CC 2014 

OS 
Microsoft Windows 7 64-bit SP1 
Microsoft Windows 8 64-bit 
Apple Mac OS X v10.8, v10.9 

CPU 
Intel Core 2 Duo or AMD Phenom II or higher,  
64-bit compatible CPU 

RAM 4 GB or higher (8 GB or higher recommended) 
Display 1280x800 or higher resolution 

* Microsoft and Windows are registered trademarks or trademarks of Microsoft Corporation of America in 

the United States and other countries. 

* Apple, Mac OS X, and Macintosh are registered trademarks of Apple Inc. in the United States and 

other countries. 

* Adobe, the Adobe logo, Premiere Pro, and After Effects are trademarks of Adobe Systems 

Incorporated. 

* Intel and Intel Core are trademarks of Intel Corporation in the United States and other countries. 

* AMD and AMD Phenom are trademarks of Advanced Micro Devices, Inc. 
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1.3. Notes on Premiere Pro / After Effects 

1.3.1. Terminology 

 

Table 1-2: Terminology 

Term Description 

Common 
 File A file existing on the disk. 

 Project 
A collection of sequences/compositions. A 
project allows you to manage multiple 
sequences/compositions and edit videos. 

 Media Encoder 
Encoding software from Adobe. The software 
can be accessed from Premiere Pro / After 
Effects and allows you to perform rendering. 

 Import 
The process of loading CLP or other files to 
Premiere Pro / After Effects. 

 Export 
The process of outputting the contents of 
sequences/compositions to a file. 

 Rendering 
The process of encoding a video and outputting it 
to a file. 

Premiere Pro 

 Sequence 

A collection of clips used in Premiere Pro. You 
can position multiple clips in a sequence to 
create a video. Sequences can also be placed on 
other sequences. 

 Clip 
The smallest unit used in video editing. Multiple 
clips pieced together make up a video. 

 Export 
The process of encoding the material on a 
sequence and outputting it to a file. 

After Effects 

 Composition 

A collection of layers used in After Effects. You 
can position multiple layers in a composition to 
create a video. Compositions can also be placed 
on other compositions. 

 Layer 
The smallest element used in video composition. 
Multiple layers placed on top of each other make 
up a composition. 
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2. Software Configuration 

The software configuration is as follows. 

 

Table 2-1: Software components 

Component Description 

Adobe Premiere Pro Video editing software. 
Adobe After Effects Video composition software. 
Adobe Media Encoder Video encoding software. 

CLP Importer 
An importer plug-in used to import CLP format 
files. A common binary format is used for 
Premiere Pro, After Effects, and Media Encoder. 

CLP Exporter 
An exporter plug-in used to export CLP format 
files. A common binary format is used for 
Premiere Pro and Media Encoder. 

 

A software configuration diagram is shown in Figure 2-1. 

 

 

Figure 2-1: Software configuration diagram 

 

When CLP Importer is installed as a plug-in, CLP format files can be handled as clips for editing. CLP 

Importer can be used as a common plug-in for Premiere Pro, After Effects, and Media Encoder. 

 

When CLP Exporter is installed as a plug-in, editing results can be exported in CLP format. CLP Exporter 

can be used as a common plug-in for Premiere Pro and Media Encoder. 

The following two methods are available for exporting sequences edited in Premiere Pro to CLP format. 
 Export to CLP format directly from Premiere Pro. 
 Send the sequence from Premiere Pro to the render queue of Media Encoder, and then export to 

CLP format from Media Encoder. 
 

On the other hand, export to CLP format from After Effects can only be performed via Media Encoder. 

Send the composition from After Effects to the render queue of Media Encoder, and then export to CLP 

format from Media Encoder. 

 

Of the above software components, this document describes the functions of CLP Importer and CLP 

Exporter. 
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3. CLP Importer Functions 

3.1. Overview 

CLP Importer includes functions for importing CLP files to Premiere Pro / After Effects. 

3.2. Supported CLP formats 

3.2.1. Supported formats list 

CLP Importer allows import of the following CLP file formats. 

Table 3-1: Supported CLP formats for import 

Mode Resolution Alpha Frame rate Remarks 

High 1920x1080 
(1088) 

Yes 59.94i  
59.94p  
50i  
50p  
23.98psf  
24psf  

No 59.94i  
59.94p  
50i  
50p  
23.98psf  
24psf  

1280x720 Yes 59.94p  
50p  

No 59.94p  
50p  

720x480 (512) Yes 59.94i Aspect ratio imported as 0.9091. 
No 59.94i Aspect ratio imported as 0.9091. 

720x576 Yes 50i Aspect ratio imported as 1.0940. 
No 50i Aspect ratio imported as 1.0940. 

Standard 1920x1080 
(1088) 

Yes 59.94i  
59.94p  
50i  
50p  
23.98psf  
24psf  

No 59.94i  
59.94p  
50i  
50p  
23.98psf  
24psf  

1280x720 Yes 59.94p  
50p  

No 59.94p  
50p  

720x480 (512) Yes 59.94i Aspect ratio imported as 0.9091. 
No 59.94i Aspect ratio imported as 0.9091. 

720x576 Yes 50i Aspect ratio imported as 1.0940. 
No 50i Aspect ratio imported as 1.0940. 
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3.2.2. Audio data 

CLP files with audio or without audio can be imported for each of the formats listed in Table 3-1. 
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4. CLP Exporter Functions 

4.1. Overview 

CLP Exporter includes functions for exporting CLP files to Premiere Pro / After Effects (Media Encoder). 

4.2. Supported CLP formats 

4.2.1. Supported formats list 

CLP Exporter allows export of the CLP file formats listed in Table 4-1. The sequence/composition 

settings that are supported by the CLP output formats are indicated in Table 4-2. 

 

Table 4-1: Supported CLP formats for export 

Mode Resolution Alpha Frame rate 

High 1920x1080 
(1088) 

Yes 59.94i 
59.94p 
50i 
50p 
23.98psf 
24psf 

No 59.94i 
59.94p 
50i 
50p 
23.98psf 
24psf 

1280x720 Yes 59.94p 
50p 

No 59.94p 
50p 

720x480 (512) Yes 59.94i 
No 59.94i 

720x576 Yes 50i 
No 50i 

Standard 1920x1080 
(1088) 

Yes 59.94i 
59.94p 
50i 
50p 
23.98psf 
24psf 

No 59.94i 
59.94p 
50i 
50p 
23.98psf 
24psf 

1280x720 Yes 59.94p 
50p 

No 59.94p 
50p 
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Mode Resolution Alpha Frame rate 

 

720x480 (512) Yes 59.94i 
No 59.94i 

720x576 Yes 50i 
No 50i 

 

Table 4-2: CLP output format to sequence/composition settings compatibility 

CLP output format Sequences/composition settings 

1920x1080 59.94i 1920x1080, 29.97 fps, from even/odd field 
1920x1080 59.94p 1920x1080, 59.94 fps, progressive 
1920x1080 50i 1920x1080, 25 fps, from even/odd field 
1920x1080 50p 1920x1080, 50 fps, progressive 
1920x1080 
23.98psf 

1920x1080, 23.98 fps, progressive 

1920x1080 24psf 1920x1080, 24 fps, progressive 
1280x720 59.94p 1280x720, 59.94 fps, progressive 
1280x720 50p 1280x720, 50 fps, progressive 
720x480  59.94i 720x480, 29.97 fps, from even/odd field 
720x576 50i 720x576, 25 fps, from even/odd field 

 

4.2.2. Maximum durations 

The maximum duration for exported clips is determined by the [Compression Level] (CLP compression 

ratio) parameter. When the [Duration Check] parameter is enabled, frames that exceed the maximum 

duration will not be encoded. In such cases, a warning will appear when encoding is complete.  

 

 

Figure 4-1: Warning displayed when maximum duration is exceeded during encoding  

(Premier Pro example) 

 

The maximum durations determined by the compression level are as follows. 

Table 4-3: Maximum durations for compression levels 

Compression level 

Maximum durations 

CLP output format 
1920x1080 / 59.94p, 50p 

CLP output format other than 
the left 

High 15 sec. 30 sec. 

Standard 30 sec. 60 sec. 
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4.2.3. Audio data 

When a sequence/composition contains audio, it is converted to "16bit 48kHz 2ch (Stereo) 

uncompressed" and output to a CLP file. 
 

4.3. Parameters 

The parameters that can be configured in CLP Exporter are as follows. 

 

Table 4-4: Exporter parameters 

Parameter Type Default Description 

Compression Level Radio button High Specifies the compression ratio used for CLP 
conversion. 
High:  0.25 compression ratio 
Standard: 0.5 compression ratio 

Alpha Channel Checkbox Enabled Specifies whether an alpha channel is present. 
Enabled: Alpha channel present 
Disabled: Alpha channel not present 

Duration Check Checkbox Disabled Specifies whether to enable duration check. 
Enabled: Duration check performed 
Disabled: Duration check not performed 

Format Drop-down list - Specifies the CLP format. 

 

4.4. Export flow 

An operation flow diagram for the export procedure follows. 

Before starting export, verify that the sequence/composition settings are of a supported format. If the 

format is not supported, an error message will appear and the procedure will end. For details on 

supported formats, see section 4.2.1. 

The operation will vary depending on whether the [Duration Check] parameter is enabled. 

When [Duration Check] (limit) is enabled, 

1. When the CLP output format is 920x1080 59.94p or 1920x1080 50p: 

Frames occurring after 15 seconds when [Compression Level] (mode) is [High] or after 30 seconds 

when [Compression Level] (mode) is [Standard] will not be encoded. 

2. When the CLP output format is other than the above: 

Frames occurring after 30 seconds when [Compression Level] (mode) is [High] or after 60 seconds 

when [Compression Level] (mode) is [Standard] will not be encoded. 

 

When [Duration Check] (limit) is disabled, encoding is performed until the end, regardless of the 

duration. 
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Figure 4-2: Export flow diagram 
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5. Installation 

5.1. Installation procedure 

Download the compressed package for your OS from the website, and extract it. Run the extracted 

"ClpPluginInstaller," and follow the instructions on the screen to perform installation. 

5.2. Deployment 

The required files and installation locations for CLP Importer and CLP Exporter are as follows. 

 

Table 5-1: Deployment for Windows 

File name Description Installation location 

ImporterCLP.prm CLP Importer 

C:\Program Files 
\Adobe\Common\Plug-ins\7.0\MediaCore\ 
* Varies depending on the Premiere Pro 
installation location. 

ExporterCLP.prm CLP Exporter 

C:\Program Files 
\Adobe\Common\Plug-ins\7.0\MediaCore\ 
* Varies depending on the Premiere Pro 
installation location. 

 

Table 5-2: Deployment for Macintosh 

File name Description Installation location 

ImporterCLP.bundle CLP Importer 
/Library/Application Support/Adobe 
/Common/Plug-ins/7.0/MediaCore/ 

ExporterCLP.bundle CLP Exporter 
/Library/Application Support/Adobe 
/Common/Plug-ins/7.0/MediaCore/ 
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6. Operation 

6.1. Importing CLP files 

6.1.1. Premiere Pro operations 

The following three methods are available for importing CLP files in Premiere Pro. 
A Drag & drop 
B Menu operation 
C Context menu operation 

 

A Drag & drop 

Drag & drop the CLP file directly from Explorer or Finder to the [Project] tab. 

 

Figure 6-1: Importing via drag & drop 

 

B Menu operation 

Select [Import] in the [File] menu to open the file selection dialog box, and select the CLP file (*.clp). 
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Figure 6-2: Importing via the menu 
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C Context menu operation 

Right-click (Ctrl + click) in the [Project] tab to display the context menu, and select [Import].  

 

Figure 6-3: Importing via the context menu 
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6.1.2. After Effects operations 

The following three methods are available for importing CLP files in After Effects. 
A Drag & drop 
B Menu operation 
C Context menu operation 

 

A Drag & drop 

Drag & drop the CLP file directly from Explorer or Finder to the [Project] tab. 

 

Figure 6-4: Importing via drag & drop 
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B Menu operation 

Select [Import] - [File] in the [File] menu to open the file selection dialog box, and select the CLP file 

(*.clp). 

Figure 6-5: Importing via the menu 
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C Context menu operation 

Right-click (Ctrl + click) in the [Project] tab to display the context menu, and select [Import] - [File]. 

 

Figure 6-6: Importing via the context menu 
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6.2. Exporting CLP files 

6.2.1. Premiere Pro operations 

While the sequence you want to export is selected in Premiere Pro, select [Export] - [Media] in the [File] 

menu. 

Figure 6-7: Opening the export settings dialog box 

 

Configure the following in the export settings dialog box. 
 Select CLP in [Format]. 
 Specify the output destination path in [Output Name]. 
 Configure the [Compression Level], [Alpha Channel], [Duration Check], and [Format] settings in the 

[Video] tab. 
 Click the [Export] button.  

(Clicking the [Queue] button here opens Media Encoder. Export will also be performed from Media 
Encoder.) 
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Figure 6-8: Export settings 

 

6.2.2. After Effects operations 

While the composition you want to export is selected in After Effects, select [Add to Adobe Media 

Encoder Queue] in the [Composition] menu. 

Figure 6-9: Opening Media Encoder 

 

Shortly after Media Encoder opens, the composition you just added will appear in the [Queue] tab. Click 

the [Format] column for the added composition. 
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Figure 6-10: Adobe Media Encoder 

 

Configure the following in the export settings dialog box. 
 Select CLP in [Format]. 
 Specify the output destination path in [Output Name]. 
 Configure the [Compression Level], [Alpha Channel], [Duration Check], and [Format] settings in the 

[Video] tab. 
 Click the [OK] button. 

Figure 6-11: Export settings 

 

Click the play button in the [Queue] tab to start export. 
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